Skip to content
CA Spectrum - 10.2 to 10.2.3
Documentation powered by DocOps

System Requirements for Linux

Last update October 11, 2018

Linux System Requirements

Linux Support

The following table summarizes CA Spectrum support for Linux operating systems:

Operating System SpectroSERVER OneClick Server OneClick Client CABI Version*
Red Hat® Enterprise Linux® 5.x
(64-bit) (Till 10.2.1)
Yes Yes Yes
(64-bit JRE)
r4.1 SP3
Red Hat Enterprise Linux 6.x
(64-bit)
Yes Yes Yes
(64-bit JRE)

r4.1 SP3, JasperReports® Server - 6.3.0

Red Hat Enterprise Linux 7.x
(64-bit)
Yes Yes Yes
(64-bit JRE)
r4.1 SP3, JasperReports® Server - 6.3.0

* Report Manager uses CABI r4.1 SP3 as the report delivery engine.  

 
Note: For information about the platforms that CABI r4.1 SP3 supports, see Supported Platforms document that is delivered with the CABI r4.1 SP3 installation media.
For information about the platforms that CA Business Intelligence JasperReports® Server - 6.3.0 supports, see  System Requirements.


Note: Perl should be installed if not available.

SpectroSERVER and OneClick Server Minimum Requirements for Linux

The following table lists the system requirements for SpectroSERVER and OneClick server on Linux platforms:

Component
Requirement
Operating System

Red Hat Enterprise Linux 5.x (64-bit) Supported till v.10.2.1


Red Hat Enterprise Linux 6.x (64-bit)

Red Hat Enterprise Linux 7.x (64-bit)

 X-based desktop environment (such as KDE or GNOME)

Memory (RAM) Dependent on the configuration and number of managed devices
Processor Dependent on the configuration and number of managed devices
Disk Space HDD:100 GB (Minimum 50 GB).
Note: This may vary depending on the configuration and number of managed devices.
Graphical User Interface Motif (32-bit). 
Note: Motif is not required for a distributed installation.
Video System Video card that supports 32-bit color at 1024x768 pixel resolution and a 20" monitor or larger.
PDF Document Viewer Acrobat Reader X or later
Packages See "Required Packages," below.
 
Important! Do not set your foreground font color to white. If this font color is set to white, you cannot read the text on your screen during the installation.

Required Packages

 
Note: For purposes of identification, 32-bit RPMs for Red Hat Enterprise Linux contain "i386" or "i686". The 64-bit RPMs contain "x86_64".

Install the following 64-bit RPMs and its dependencies, for the respective RHEL version:

  • elfutils-libelf
  • libaio (required for MySQL v5.5, the MySQL version for the database)
  • ncurses
  • ncurses-libs (RHEL 6.x or 7.x)
  • xterm
  • ksh
  • xorg-x11-fonts-misc 

  • PackageKit-gtk-module or PackageKit-gtk3-module (for RHEL 7.x)

  • libcanberra-gtk2 

  • gtk2-engines (not required for RHEL 6.4 or later versions)

Install the following 32-bit and 64-bit RPMs and its dependencies, for the respective RHEL version:

  • openmotif (RHEL 5.x, 6.x) or motif (RHEL 7.x)
  • glibc
  • nss-softokn-freebl
  • libICE
  • libSM
  • libX11
  • libXext
  • libXft
  • libXmu
  • libXp
  • libXrender
  • libXt
  • fontconfig
  • freetype
  • libjpeg (RHEL 5.x) or libjpeg-turbo ( RHEL 6.x,7.x)
  • libpng
  • libuuid
  • libxcb
  • libXau
  • expat
  • zlib
  • libstdc++
  • libgcc
  • libXi
  • libXtst

OneClick Client Minimum Requirements for Linux

The following table lists the OneClick client requirements for Linux platforms:

Component
Requirement
Operating System

Red Hat Enterprise Linux 5.x (64-bit) Supported till v.10.2.1
Red Hat Enterprise Linux 6.x (64-bit)

Red Hat Enterprise Linux 7.x (64-bit)
X-based desktop environment (such as KDE or GNOME)

Memory (RAM) Dependent on the configuration and number of managed devices
Processor Dependent on the configuration and number of managed devices
Disk Space Dependent on the configuration and number of managed devices
Graphical User Interface X11 system that the JRE supports
Java Components

Important! Java 8 with x64 JRE is mandatory for OneClick Client.

Java 2 Run-time Environment (JRE) version 1.8.0_121 (64-bit) for CA Spectrum 10.2.3, 10.2.2, 10.2.1.

Web Browser

Firefox 10.0 or later. 

Video System Video card that supports 32-bit color at 1024x768 pixel resolution and 20" monitor or larger.
 

Important! CA Spectrum 10.1 does not officially support 32-bit Java clients.

Was this helpful?

Please log in to post comments.

  1. Leo Purcell
    2017-12-21 11:13

    Need to update the 64-bit RPMs to show that:

    PackageKit-gtk-module PackageKit-gtk*-module

    (This is required for RHEL 7.4 install

  2. Leo Purcell
    2017-12-21 11:16

    Need to update the 64-bit RPMs to show that:

    PackageKit-gtk-module PackageKit-gtk*-module

    (This is required for RHEL 7.4 install which supports requires PackageKit-gtk3-module)

    1. Vijaya Kumar Gonela
      2017-12-22 07:31

      Update

      Hi Leo Purcell,

      The engineering confirmed that PackageKit-gtk3-module is required for RHEL 7.x. So, we have updated the Required Packages section accordingly.

      Thanks again for your feedback!

      Regards,
      Team DocOps

      ---------------------------------------------------------------- 

      Hi Leo Purcell,

      Thanks for sharing this information!
      We will check with engineering team and make the required updates at the earliest.

      Regards,
      Team DocOps 

  3. Tomas Vrbka
    2018-01-31 05:12

    Install 32bit package version by suffixing .i686: yum install motif.i686 glibc.i686 nss-softokn-freebl.i686 libICE.i686 libSM.i686 libX11.i686 libXext.i686 libXft.i686 libXmu.i686 libXp.i686 libXrender.i686 libXt.i686 fontconfig.i686 freetype.i686 libjpeg-turbo.i686 libpng.i686 libuuid.i686 libxcb.i686 libXau.i686 expat.i686 zlib.i686 libstdc++.i686 libgcc.i686 libXi.i686 libXtst.i686

  4. Tomas Vrbka
    2018-01-31 12:07

    Installed Perl is a must too.

  5. Shane Ryan
    2018-07-16 07:05

    the Java component section is missing for 10.2.3

    Java Components Java 2 Run-time Environment (JRE) version 1.8.0_144 (64-bit) for CA Spectrum 10.2.2. Java 2 Run-time Environment (JRE) version 1.8.0_112 (64-bit) for CA Spectrum 10.2.1.

    On the OC web page for 10.2.3, it offers a dl of 121.

    Please clarify what is the requirement for 10.2.3?

    thanks

    1. Channa Puchakayala
      2018-08-19 10:16

      For All 10.2.1, 10.2.2 and 10.2.3, required Java 2 Run-time Environment (JRE) version is 1.8.0_121(64-bit)

      @Vijaya, please update above documentation accordingly.