Skip to content
CA App Synthetic Monitor
Documentation powered by DocOps

Pre-Installation check list

Last update January 24, 2019

Prerequisites

If you have all the following software and hardware elements, you can move directly to installing an On-premise monitor.

Check Required Details Cautions
  •  
Hardware Min, Med, or Max See the table below. Availability of functions depends upon hardware capabilities.
  •  
Network Access Outbound port 443 must be open. Alternatively, an HTTP proxy can be used. Only HTTP proxy (with optional password authentication) can be used. HTTPS and SOCKS proxies are not supported.
  •  
Software

Debian 8, Red Hat Enterprise Linux 7, or CentOS 7 operating system with all the required packages, see Software Requirements.

Ensure that you follow the steps in Software Requirements during the OS installation.
  •  
Access rights The OPMS installer must be run under the root user. Running the installer using sudo is not supported.

Hardware Requirements

The server hardware limits the type and number of agents that the OPMS can run. These hardware requirements also apply to virtual machine installations.


Minimum Adequate Optimum
Operating System

Debian GNU/Linux 8
Red Hat Enterprise Linux 7
Oracle Linux 7
CentOS 7

Debian GNU/Linux 8
Red Hat Enterprise Linux 7
Oracle Linux 7
CentOS 7
Debian GNU/Linux 8
Red Hat Enterprise Linux 7
Oracle Linux 7
CentOS 7
CPU Cores 2 or more cores at 2 GHz or higher 4 or more cores at 2 GHz or higher 4 to 8 core at 2 GHz or higher
Memory 2 GB or more 4 GB or more 8 GB or more
Swap Space 1 GB or more 1 GB or more 1 GB or more
Disk Space 50 GB or more 100 GB or more 250 GB or more
Disk I/O Low Medium High
Network Bandwidth 10 Mbit or more 10 Mbit or more 100 Mbit
IPv6 Support
Yes, native or tunneled Yes, native. Tunnels are not recommended.

Minimum hardware requirements
A minimal OPMS host can run all agents except the RBM.

Medium hardware requirements
A moderately sized OPMS host can run up to 5 RBMs concurrently.

Optimum hardware requirements
An optimal OPMS host can run at least five RBMs concurrently.

Bare metal hardware is recommended for optimum performance, but a virtual machine can be used too. For information about compatibility with Debian 8 or RedHat/Oracle Linux/CentOS 7.x, refer to your virtualization solution provider.

Software Requirements

OPMS requires one of the following operating systems:

  • Debian 8
  • Red Hat Enterprise Linux 7.x
  • Oracle Linux 7.x
  • CentOS 7.x

To use the OPMS installer graphical interface, the graphical desktop environment must be present. You can also use a text console for installing the OPMS.

Follow these steps to install the operating system:

  1. Obtain the installation image for your Linux distribution.
  2. Run the OS installer on the host.
  3. Specify the hostname. Do not use the suggested default localhost.
  4. Specify your network domain in the format <domain>.<TLD>. Do not use the suggested default local domain.
  5. Specify the partition layout.
    • Debian: The default layout is recommended.
    • RHEL / CentOS / Oracle Linux: Delete the /home partition and enlarge root partition to fill the unused space.
  6. Optionally, specify the HTTP proxy for the download of installation packages. Proxy configuration that is entered in this step is used by the OPMS Installer and On Premise Monitoring Stations (OPMS).
  7. Specify the following software selection:
    • Debian

      • SSH server
      • Standard system utilities
      • Graphical desktop environment (optional)
    • RHEL / CentOS / Oracle Linux
      • Server with GUI
  8. Post-installation requirements:
    • Oracle Linux:
    • RHEL:
      • The installer needs access to the rhel-7-server-optional-rpms and rhel-7-server-extras-rpms repositories. The repositories are enabled automatically during install which requires a valid RHEL subscription. If you do not have a valid RHEL subscription, you must either provide access to the repositories or you install all required packages manually. Contact support to obtain the list of required packages.
  9. Install Java Runtime Environment (JRE) version 8 (OpenJDK which is available in all supported Linux distributions can be used).
Was this helpful?

Please log in to post comments.

  1. Anonymous
    2015-10-21 12:44

    Great reorganization of this page!

  2. MIKE COOK
    2016-11-10 09:36

    the http proxy link doesn't work - (content says underconstruction so just get a pge not found)

  3. Martin Macura
    2016-12-01 08:14

    Having /opt and /etc on separate filesystems will cause the installation to fail.

  4. Ruth Wunderle
    2016-12-01 10:12

    In the section "Software Requirements" step 4 the partition layout results in Page not found

  5. Daniel Eig
    2017-03-24 11:55

    Java 8 is also required with the latest versions of the OPMS. Can we update the software requirements to reflect this?

  6. VICTOR BEJERANO
    2017-06-27 11:34

    The http proxy and tunnel client link doesn't work - (content says underconstruction so just get a pge not found).

    Please could you check it.

  7. Sergio Morales Correa
    2017-07-05 06:17

    Hello, Please add Java 1.8 as an important requirement for the opms installer. Thanks. A customer reported DE303042, he was unable to install opms, there was no puppet.log log created, only the install log and it contains the below errors. +++ Stack Trace: java.lang.NullPointerException at com.zerog.ia.installer.ConsoleBasedAAMgr.ad(Unknown Source) ++ Solution was to use 1.8. From Sustaining: Rally Defect # DE303042 Updated by sedpe03 Hi Sergio, From the installer log it's clear that the customer has Java 1.6 installed. That's not supported, Java 1.8 is required

    1. Petr Sedlacek
      2017-07-26 09:14

      Added.

  8. Gary Jones
    2017-11-22 06:26

    Also please add that we require various Repositories to be enabled or if Redhat that it's registered via Subscription Manager.

    1. Lucie Stehnova
      2017-11-22 08:58

      Hi Gary,

      Thank you for your comment. We'll work on this with the development team.

      Lucie

  9. Daniel Eig
    2017-11-29 02:29

    Step 6 has multiple links that don't work. Where are they supposed to go? 6. Optionally, specify the HTTP proxy for the download of installation packages. Proxy configuration that is entered in this step is used by the OPMS Installer and tunnel client.

  10. MIKE COOK
    2018-07-06 03:10

    The rhel-7-server-extras-rpms requirement is documented but it also needs to be the latest - see problem described in https://comm.support.ca.com/kb/asm-on-premise-installation-failed-on-fresh-rhel-install/KB000104027 -

    1. Joshua Lajciak
      2018-07-09 03:02

      Hi Mike,

      Thank you for your comment. We'll update the documentation with the latest requirements.

      Josh