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Chapter 1: Introduction
Unified Reporter (UR) is an optional component that provides advanced reporting for
the Unified Management Portal (UMP).
UR provides the following features:
■

Drag and drop ad hoc report building.

■

Drag and drop dashboard building, with live refresh, and mashups of external
content.

■

Built-in charting that includes pie, bar, line, multi-series, area, and many other chart
types.

■

A library of out-of-box (OOB) reports that save time and effort.

■

Database abstraction using JSON query extractors.

■

Self-service parameterized web reporting.

■

Report scheduling, distribution, and historical versioning.

■

Access to any data source, including the Nimsoft SLM database.

In addition, UR provides developers and power users with:
■

The iReport graphical report designer for building more complex reports.

■

Print-ready pixel-perfect production reporting.

This document provides information on the basic use of UR and iReport.
Additional UR documentation is available in the Unified Management Portal
web-based help.
This section contains the following topics:
Obtaining Unified Reporter (see page 8)
Users and Permissions (see page 8)
Folder Structure (see page 9)
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Obtaining Unified Reporter

Obtaining Unified Reporter
Additional licensing is not required to use UR, but UR is not automatically installed with
UMP.
Before you install UR, install UMP, and then obtain the appropriate UR install package
for your environment from the Downloads page at support.nimsoft.com. Read and
understand the Unified Reporter Release Notes and Unified Reporter Installation Guide,
both available at docs.nimsoft.com, before installing UR.
After you install UR, you can access it from the Reports page in UMP, or you can add it
to a page of your choice.

Users and Permissions
Users must have the ACL permission Unified Reports to access UR.
UR users comprise two types: account contact users and NMS users. Account contact
users can only see the Public > Nimsoft Monitor folder, and the folder to which they
belong. By default, account contact users have read-only access to the repository, unless
they have the Portal Administration permission, which grants them full access to their
account folder only.
NMS users with the Portal Administration permission can see the folders of all of the
accounts, and have full access to the repository.

Add Users in NMS
Unified Reporter (UR) users must be added in NMS with Infrastructure Manager.
The UR web application (JasperReports Server Pro) provides a way to add users.
However, authentication is handled by NMS. If you add a user in UR and then try to log
in with that user name, it will not work. Add the user in NMS using Infrastructure
Manager, and then log in to UR.
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Folder Structure

Folder Structure
In UR 6.5, the Nimsoft Monitor out-of-box (OOB) reports in the repository are
consolidated under the folder Public > Nimsoft Monitor. Folders are automatically
created for accounts when account contact users log in for the first time.
When you upgrade to UR 6.5, the OOB reports are automatically placed under Public >
Nimsoft Monitor, and removed from the former location in the directory structure.
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Chapter 2: Out-of-box Reports
This section provides information about the out-of-box (OOB) reports included with UR.
This section contains the following topics:
Options for Out-of-box Reports (see page 11)
List of Out-of-box Reports (see page 12)

Options for Out-of-box Reports
When you run an OOB report from the repository, the Options pane appears on the
left-hand side. The Options pane allows you to customize the report by selecting from
the following fields:
Top #
Allows you to set the number of results to 5, 10, or 25. By default this value is set to
10.
Time period
Allows you to set last hour, last day, last week, last month, or last year. By default
this value is set to last day.
Ignore Pagination
This check box allows you to view an entire report on one page by scrolling down,
rather than by paging through the report. This option can be useful for reports with
considerable data, or if you plan to print the report. By default, pagination is
enabled.
Note: With reports of time-series data, such as CO2 Emissions Rate, the Options pane
only displays the Time period field.
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List of Out-of-box Reports

Editing the Default List of Values
NMS users with the Portal Administration ACL permission can edit the values that
appear in the Top # and Time period lists in the Options pane. All Nimsoft Monitor OOB
reports inherit their options from the Top # and Time period lists. Therefore, when you
edit the default list of values, the changes are applied to all of the Nimsoft Monitor OOB
reports.
Follow these steps:
1.

From the repository view, expand Public > Nimsoft Monitor > resources > lists.

2.

Select either Time period or Top #, and click Edit in the toolbar.

3.

In the Edit List of Values panel, add or remove the values in the drop-down list.
Note: The values that you specify for the Time period must be consistent with your
database provider.

List of Out-of-box Reports
The following table lists the OOB reports that come with UR. It also lists the probes that
must be activated, and the QoS measurement(s) that must be enabled on the probe in
order to obtain data for each report.

Report Category Report Name

QoS Required

Probe

Applications

Active Directory Replication Age

QOS_AD_REPLICATION_AGE

ad_response

Applications

End to End User Transactions

QOS_E2E_EXECUTION

e2e_appmon

Applications

Remedy Response Time

QOS_REMEDY_REPONSE

remedy_response

Applications/Ap
ache

Apache Busy Workers

QOS_APACHE_BUSYWORKERS

apache

Applications/Ap
ache

Apache Bytes per Request

QOS_APACHE_BYTESPERREQ

apache

Applications/Ap
ache

Apache HTTP Response Time

QOS_APACHE_HTTPRESTIME

apache

Applications/Ap
ache

Apache Idle Workers

QOS_APACHE_IDLEWORKERS

apache

Applications/Ap
ache

Apache Requests Average Time

QOS_APACHE_REQAVETIME

apache

Applications/Ap
ache

Apache Requests Per Second

QOS_APACHE_REQPERSEC

apache
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List of Out-of-box Reports

Databases/MyS
QL

MySQL % of Maximum Allowed
Connections

QOS_MYSQL_CONNECTION_USAGE_ mysql
RATE

Databases/Oracl Oracle % Table Space Free
e

QOS_ORACLE_TABLESPACE_FREE

oracle

Databases/Oracl Oracle Databases by Size
e

QOS_ORACLE_DATABASE_SIZE

oracle

Databases/Oracl Oracle SGA Memory Free
e

QOS_ORACLE_SGA_MEMORY_FREE

oracle

Databases/Oracl Oracle Table Space Allocated Free QOS_ORACLE_TABLESPACE_ALLOC_F oracle
e
REE
Databases/SQL
Server

SQL Server Free Allocated Space

QOS_SQLSERVER_ALLOC_SPACE

sql_server

Databases/SQL
Server

SQL Server Response Time

QOS_SQL_RESPONSE

sql_response

Databases/SQL
Server

SQL Server Transactions

QOS_SQLSERVER_TRANSACTIONS

sql_server

Databases/SQL
Server

SQL Server Users

QOS_SQLSERVER_ACTIVE_USERS

sql_server

Network

DHCP Response Time

QOS_DHCP_RESPONSE

url_response

Network

DNS Response Time

QOS_DNS_RESPONSE

url_response

Network

Hosts by Response Time

QOS_NET_CONNECT

net_connect

Network

Interfaces by Bandwidth Inbound

QOS_INTERFACE_TRAFFIC_PERC

interface_traffic

Network

Interfaces by Bandwidth
Outbound

QOS_INTERFACE_TRAFFIC_PERC

interface_traffic

Network

Interfaces by Discards

QOS_INTERFACE_DISCARDS

interface_traffic

Network

Interfaces by Errors

QOS_INTERFACE_ERRORS

interface_traffic

Network

Interfaces by Queue Length

QOS_INTERFACE_QLEN

interface_traffic

Network

LDAP Response Time

QOS_LDAP_RESPONSE_TIME

ldap_response

Network

NTP Response Time

QOS_NTP_RESPONSE_TIME

ntp_response

Network

URLs by Response Time

QOS_URL_RESPONSE

url_response

Network/Cisco

Cisco by Memory Free

QOS_MEMORY_USAGE

cisco_monitor

Network/Cisco

Cisco by Memory Used

QOS_MEMORY_USAGE

cisco_monitor

Network/Cisco

Cisco CallManager CPU Usage

QOS_CPU_USAGE

ccm_monitor

Network/Cisco

Cisco CallManager Memory Used
(%)

QOS_CCM_PERFORMANCE

ccm_monitor
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List of Out-of-box Reports

Network/Cisco

Cisco CPU Usage

QOS_CPU_USAGE

cisco_monitor

Network/Cisco

Cisco QoS Drop Bitrate

QOS_CISCO_DROP_BITRATE

cisco_qos

Network/Cisco

Cisco QoS Post Policy Bitrate

QOS_CISCO_POST_POLICY_BITRATE

cisco_qos

Network/Cisco

Cisco QoS Post Policy Bytes

QOS_CISCO_POST_POLICY_BYTE

cisco_qos

Network/Cisco

Cisco QoS Pre Policy Bitrate

QOS_CISCO_PRE_POLICY_BITRATE

cisco_qos

Power

CO2 Emissions Rate

QOS_CO2_EMISSIONS_RATE

power

Power

Data Center Infrastructure
Efficiency

QOS_DCIE

power

Power

Power Usage Effectiveness

QOS_PUE

power

Servers

Servers By CPU Usage

QOS_CPU_USAGE

cdm (local) or rsp
(remote)

Servers

Servers by Disk Capacity

QOS_DISK_USAGE_PERC

cdm (local) or rsp
(remote)

Servers

Servers by Physical Memory

QOS_MEMORY_PHYSICAL_PERC

cdm (local) or rsp
(remote)

Servers

Servers by Processor Queue
Length

QOS_PROC_QUEUE_LEN

processes

Servers/Process
es

Processes by CPU Usage

QOS_PROCESS_CPU

processes

Servers/Process
es

Processes by Memory Usage

QOS_PROCESS_MEMORY

processes

Servers/Process
es

Processes by Thread Count

QOS_PROCESS_THREADS

processes

ServiceDesk

Accounts (NMS) by Events

nsdgtw

ServiceDesk

Accounts (ServiceDesk) by
Incidents

nsdgtw

ServiceDesk

Applications by Events and
Incidents

nsdgtw

ServiceDesk

Devices by Mean Time to Repair
vs Service Quality

nsdgtw

ServiceDesk

Network Events and Incidents

nsdgtw

ServiceDesk

Servers by Events and Incidents

nsdgtw

Virtualization/V
Mware

VMware Guests by CPU MHz

QOS_CPU_USAGE_MHZ

vmware

Virtualization/V
Mware

VMware Guests by CPU Usage

QOS_CPU_USAGE

vmware
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List of Out-of-box Reports

Virtualization/V
Mware

VMware Hosts by CPU Usage

QOS_CPU_USAGE

vmware

Virtualization/V
Mware

VMware Hosts by Disk Free

QOS_DISK_FREE

vmware

Virtualization/V
Mware

VMware Hosts by Memory Usage

QOS_MEMORY_PERC_USAGE

vmware

Virtualization/V
Mware

VMware Hosts by VM Count

QOS_COUNTER

vmware
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Chapter 3: Designing an Ad Hoc View
This section describes how to design an ad hoc view in UR. After you create an ad hoc
view, you can save and open the ad hoc view as a report.
Note: In addition to the Unified Reporter ACL permission required to access UR, you
must have the Portal Administration ACL permission to design a report.
Follow these steps:
1.

Log in to UMP, and go to Unified Reporter.

2.

On the landing page, click Create > Ad Hoc View.
The Data Chooser wizard opens.

3.

In the Data Chooser:
a.

Select Topics at the top of the Data Chooser.

b.

Expand the Public folder and browse to Ad Hoc Components > Topics >
Nimsoft Monitor Topic.

c.

Select Table, Chart, or Crosstab from the types of views at the bottom of the
Data Chooser.
The Input Controls dialog opens.
Note: If the Input Controls dialog does not open, click the Input Controls icon in
the Ad Hoc Editor tool bar.

4.

5.

In the Input Controls dialog:
a.

Specify a time period for the ad hoc view.

b.

Select the desired input controls from the QoS, Source, and Target lists.

c.

Click OK.

Drag and drop or double-click fields and measures to add them to the ad hoc view.
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List of Out-of-box Reports

6.

Click the Save icon when you are satisfied with the ad hoc view.
a.

Enter a name for the report.

b.

Browse to a location in the repository, and click Save.

The ad hoc view and its corresponding report now appear in the repository. You can run
the report, or further edit the ad hoc view.
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Chapter 4: Setting up iReport
After you install Unified Reporter (UR), use the steps in this section to set up iReport.
You can install iReport on any system with network access to the system on which you
installed UR.
Note: The iReport application must be correctly configured before you can modify,
copy, or run reports that use a query executer language. You can view out-of-box
reports in UR, however, you cannot edit or copy out-of-box reports without iReport.
This section contains the following topics:
Set up iReport (see page 19)
Query Executers (see page 22)
Installing the iReport Commercial License (see page 23)

Set up iReport
Follow these steps:
1.

Download the appropriate version of iReport from the Downloads page at
support.nimsoft.com.

2.

Install iReport on a system with network access to the system on which you
installed UR.

3.

Obtain libraries from the UR deployment:

4.

a.

Enter the following URL in a browser:
http://<UMP_server>/jasperserver-pro/ireport-config.jar.

b.

Save the JAR file to a location of your choice.

c.

Start iReport.

d.

Add the JAR file to the iReport classpath:
■

In the menu bar in iReport, select Tools > Options > Classpath.

■

Click Add JAR, and browse to the location where you saved the JAR file.
Click Open.

Add query executers:
a.

In the menu bar in iReport, select Tools > Options > Query Executers.

b.

Add query executers (see page 22).
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Set up iReport

5.

Connect iReport to your UMP server:
a.

In the menu bar in iReport, click Window > JasperReports Server Repository.
The Repository Navigator pane opens.

b.

Click the Add new server icon to connect to the UR instance.

The JasperServer Plugin dialog opens.

6.

c.

In the ID field, provide a name for your UMP server. For example, enter Unified
Reporter.

d.

In the JasperReports Server URL field, edit localhost:8080 so that it points to
your UMP server.

e.

Provide a valid Nimsoft username and password.

Set up the data source:
a.

Click the Report Database icon.

The Connections / Datasources dialog opens.
b.

Select New > Database JDBC connection. Click Next.
The Database JDBC connection dialog opens.

c.
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Provide a name, such as NIS, for the database JDBC connection.

Set up iReport

d.

Click the drop-down menu in the JDBC Driver field, and select the appropriate
JDBC driver for your database.
The JDBC URL field updates and displays a URL template for the specific JDBC
driver you selected. For example, if you selected MS SQLServer (2005)
(com.microsoft.sqlserver.jdbc.SQLServerDriver), the JDBC URL field displays
jdbc:sqlserver://localhost:1433;databaseName=DatabaseName.
Note: The JDBC drivers that are available are shown in black font; the JDBC
drivers that are not available are shown in red font. If the appropriate JDBC
driver is not available, verify that you added the JAR file to the classpath as
described in step 3.

e.

In the JDBC URL field, enter the IP address (or host name) of the database
server, and the database name. For example, if you selected MS SQLServer
(2005) (com.microsoft.sqlserver.jdbc.SQLServerDriver), enter
jdbc:sqlserver://<IP_address>:1433;databaseName=<NimsoftSLM>.
Note: In most cases, the JDBC connection uses the same information as the
data_engine database configuration.

f.

Provide a username and password.
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Query Executers

g.

Click the Test button.If the connection was successful, click Save.
If the connection was unsuccessful, verify the following items:
■

You selected an appropriate JDBC driver for your database.

■

You entered valid information in the JDBC URL field, and valid credentials.

■

The system on which you installed iReport has network access to the
database.

iReport is now installed and you can start using it to modify, copy, or run reports.

Query Executers
The following table lists the Nimsoft query executers you can add in iReport.

Language

Query Executer Factory

Fields Provider Class

NimsoftJSONTopN

com.nimsoft.ur.jrs.executer.NimsoftJSONTop com.nimsoft.ur.ireport.fieldsprovider.Nims
NFactory
oftJSONTopNFP

NimsoftJSONTimeSe com.nimsoft.ur.jrs.executer.NimsoftJSONTim com.nimsoft.ur.ireport.fieldsprovider.Nims
ries
eSeriesFactory
oftJSONTimeSeriesFP
nimsoft

com.nimsoft.ur.jrs.executer.NimsoftFactory

com.nimsoft.ur.ireport.fieldsprovider.Nims
oftFP

ServiceDesk

com.nimsoft.ur.jrs.executer.ServiceDeskFact
ory

com.nimsoft.ur.ireport.fieldsprovider.Servic
eDeskFP

ServiceDeskNMS

com.nimsoft.ur.jrs.executer.ServiceDeskNMS com.nimsoft.ur.ireport.fieldsprovider.Servic
Factory
eDeskNMSFP

NMS

com.nimsoft.ur.jrs.executer.NMSFactory
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com.nimsoft.ur.ireport.fieldsprovider.NMSF
P

Installing the iReport Commercial License

Installing the iReport Commercial License
iReport initially uses an evaluation license that provides commercial-license
functionality for 30 days after the installation. iReport is still usable after the evaluation
license expires, but certain features are no longer available.
You can install the commercial license that is provided in the UR installation files to
continue using all of the commercial iReport features.
Follow these steps:
1.

Open iReport.

2.

Select Help > License Manager in the toolbar.

3.

Click Install License and browse to the license file in
<nimsoft_installation>\probes\service\wasp\conf\jasperserver.license.
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Chapter 5: Using Custom Nimsoft Query
Languages
The out-of-box reports installed with UR use the custom query languages
NimsoftJSONTopN and NimsoftJSONTimeSeries, which are installed to the Unified
Reporter web app. This section provides information on using the NimsoftJSONTopN
and NimsoftJSONTimeSeries query languages.
Note: The iReport application must be correctly configured before you can modify,
copy, or run reports using a custom Nimsoft query language. See the section Setting Up
iReport (see page 19).
This section contains the following topics:
NimsoftJSONTopN Query Language (see page 25)
NimsoftJSONTimeSeries Query Language (see page 26)

NimsoftJSONTopN Query Language
This section provides information on using the NimsoftJSONTopN query language.
The NimsoftJSONTopN language expects a string representation of a JSON object. In
addition:
■

The JSON object must contain a topNReportDefinition object.

■

The topNReportDefinition object must contain the qos key, the value of which
is a string of the QoS metric for the desired report.

For example, the following syntax reports the average value of
QOS_MEMORY_PHYSICAL_PERC for each source that is collecting this data over the last
24 hours.
NimsoftJSONTopN Example 1
{"topNReportDefinition": {
"qos":"QOS_MEMORY_PHYSICAL_PERC"
}
}
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NimsoftJSONTimeSeries Query Language

In the next example, the following syntax will report the top five, average, minimum,
and maximum values of QOS_PROCESS_CPU over the last 30 minutes on the machine
cadev.dev.fco.
NimsoftJSONTopN Example 2
{"topNReportDefinition": {
"numberOfBars":5,
"statistics":["avg", "max", "min"],
"qos":"QOS_PROCESS_CPU",
"source":"cadev.dev.fco",
"period":30,
"periodUnits":"minute",
"groupFirstBy": "target"
}
}

Refer to the table below for additional, optional values you can provide in the
topNReportDefinition object to further define the report.

Key

Description

Value Datatype

Default Value

statistics

Define the statistics to collect
for the report. Options: avg,
min, max

JSONArray

"statistics":["avg"]

numberOfBars

Restricts the report to the top
# of results

Integer

"numberOfBars":10

source

Restricts the report to a
specific source

String

Matches any source

target

Restricts the report to a
specific target. Can also be
special token "{source}" to
match where target=source

String

Matches any target

period

Restricts the report to a given
interval length

Long

"period":24

periodUnits

This defines the units for the
String
period. Options: minute, hour,
day, month

"periodUnits":"hour"

groupFirstBy

Can be either source or target

"groupFirstBy":"source"

String

NimsoftJSONTimeSeries Query Language
This section provides information on using the NimsoftJSONTimeSeries query language.
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NimsoftJSONTimeSeries Query Language

The NimsoftJSONTimeSeries language expects a string representation of a JSON object.
In addition:
■

The JSON object must contain a timeSeriesReportDefinition object.

■

The timeSeriesReportDefinition object must contain the qos key, the value of
which is a string of the QoS metric for the desired report.

For example, the following syntax reports the average value of
QOS_MEMORY_PHYSICAL_PERC for each source that is collecting this data over the last
24 hours.
NimsoftJSONTimeSeries Example 1
{"timeSeriesReportDefinition": {
"qos":"QOS_MEMORY_PHYSICAL_PERC"
}
}

Refer to the table below for additional, optional values you can provide in the
timeSeriesReportDefinition object to further define the report.

Key

Description

Value Datatype

Default Value

source

Restricts the report to a
specific source

String

Matches any source

target

Restricts the report to a
specific target. Can also
be special token
"{source}" to match
where target=source

String

Matches any target

period

Restricts the report to a
given interval length

Long

"period":24

periodUnits

This defines the units for String
the period. ["minute",
"hour", "day", "month"]

"periodUnits":"hour"

measurementScale

Scales the measurement
values returned by this
value

Double

"measurementScale":1

measurementOffset

Offsets the
measurement values
returned by this value

Double

"measurementOffset":0

percentileLine

Provides a horizontal
Boolean
percentile line calculated
at the time the report is
run [true, false]

"percentileLine":false
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NimsoftJSONTimeSeries Query Language

percentileValue
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The value for the
percentile line [0-100]

Double

"percentileValue":95.0

